Fluttrfly's Flying

Troubleshooting

Why does Play Store say that my 'device isn't compatible with this version' when I try to install Fluttr?
Fluttr's minimum version requirement for installing the app on Android devices is Android 8.0. To ensure your version is up to date, go to Settings...
Fri, 18 Feb, 2022 at 10:48 AM
I sent my YOTI details to Fluttr, but the verification process doesn’t finalise and I can’t fully access the app. What should I do?
If, after you’ve sent your YOTI details over to Fluttr, you find yourself being redirected back to the ‘verify with YOTI’ screen on Fluttr and are seemingly...
Fri, 18 Feb, 2022 at 10:50 AM